Xcode 9.1 (9B55) failed to export with "Stripping extended attributes failed"

xcode9.1

317 观看

2回复

31 作者的声誉

Xcode 9.1 (9B55) failed to export with error of Stripping extended attributes failed and below error message:

/usr/bin/xattr -crs /var/folders/mm/h01jykrs7gv9w7jjb0yt609w0000gp/T/XcodeDistPipeline.FZT/Root/Payload/GitSmartHome.app" exited with a non-zero status. The /usr/bin/xattr tool may be damaged.

In IDEDistributionPipeline.log, can see below error:

2017-11-01 14:02:24 +0000
2017-11-01 14:02:24 +0000  Running /usr/bin/xattr '-crs' '/var/folders/mm/h01jykrs7gv9w7jjb0yt609w0000gp/T/XcodeDistPipeline.U1x/Root/Payload/GitSmartHome.app'
2017-11-01 14:02:24 +0000  option -c not recognized
usage: xattr [-lz] file [file ...]
       xattr -p [-lz] attr_name file [file ...]
       xattr -w [-z] attr_name attr_value file [file ...]
       xattr -d attr_name file [file ...]
The first form lists the names of all xattrs on the given file(s).
The second form (-p) prints the value of the xattr attr_name.
The third form (-w) sets the value of the xattr attr_name to attr_value.
The fourth form (-d) deletes the xattr attr_name.
options:
  -h: print this help
  -l: print long format (attr_name: attr_value)
  -z: compress or decompress (if compressed) attribute value in zip format
2017-11-01 14:02:24 +0000  2017-11-01 14:02:24 +0000
2017-11-01 14:02:24 +0000  /usr/bin/xattr exited with 64

I searched and tried a lot from the web before see this error, the question is how to fix or reinstall xattr or python of original MacOS? Does re-install High Sierra fix that?

Your advice is appreciated.

作者: Robin 的来源 发布者: 2017 年 11 月 2 日

回应 (2)


0

152 作者的声誉

Hello,Has your problem been resolved ? I get the same problem with you. enter image description here

作者: xander-ye 发布者: 27.11.2017 05:51

0

1 作者的声誉

I have a solution that maybe help you. I run cmd "/usr/bin/xattr -crs ***" in terminal and get:

python version 2.7.14 can't run /usr/bin/xattr.  Try the alternative(s): 
/usr/bin/xattr-2.7 (uses python 2.7)

then I run cmd

$ sudo mv xattr xattr_bak
$ sudo mv xattr-2.7 xattr

it worked in my xcode9.1.

作者: iprowq 发布者: 20.03.2018 03:34
32x32