Angular 5和NPM

angular npm angular5

2785 观看

3回复

是否可以使用npm安装Angular 5依赖关系(当前在RC阶段)?

此命令不显示Angular 5依赖项:

npm show @angular/core@* version

或者可以从存储库下载并安装:https : //github.com/angular/angular/

谢谢

作者: Sergey 的来源 发布者: 2019 年 11 月 9 日

回应 (3)


7

免责声明:Angular 5已发布(2017年11月1日),这是升级到它的npm命令(Windows语法):

npm install @angular/animations@'^5.0.0' @angular/common@'^5.0.0' @angular/compiler@'^5.0.0' @angular/compiler-cli@'^5.0.0' @angular/core@'^5.0.0' @angular/forms@'^5.0.0' @angular/http@'^5.0.0' @angular/platform-browser@'^5.0.0' @angular/platform-browser-dynamic@'^5.0.0' @angular/platform-server@'^5.0.0' @angular/router@'^5.0.0' typescript@2.4.2 rxjs@'^5.5.2'
npm install typescript@2.4.2 --save-exact

另外,您可以在此处阅读有关该版本的更多信息:https : //blog.angular.io/version-5-0-0-of-angular-now-available-37e414935ced

您可以在此处找到升级指南:https : //angular-update-guide.firebaseapp.com

作者: Wagner da Silva 发布者: 06.11.2017 04:38

1

请遵循以下指示:

npm uninstall -g angular-cli

然后

npm uninstall --save-dev angular-cli

npm uninstall -g @angular/cli

清理缓存

npm cache clean -f)或(npm cache verify

全局安装角度

npm install -g @angular/cli@latest
local project setup if you have one
rm -rf node_modules

npm install --save-dev @angular/cli@latest

最后,

npm install

希望这可以帮助!

作者: Enayat 发布者: 09.11.2017 03:51

0

尝试运行npm update命令。这将自动更新所有必需的依赖项和文件。运行命令后,您可以通过运行ng -version检查版本

作者: Amit Anand 发布者: 09.01.2019 08:54
32x32