GoogleMaps and GoogleAds in swift

swift xcode google-maps

102 观看

2回复

1075 作者的声誉

I have project that uses GoogleMaps. Project works fine.

but I have moved project from vm mac to other computer mac os. after that, project raised error like below.

No such module 'GoogleMaps'

why is this error raised after move project? thank you.

(and in other project that I moved, I have met like this error

  Umbrella header 'GoogleMobileAds.h' not found
  Could not build Objective-C module 'GoogleMobileAds'

this project has bridge file but that's for other library ) any idea for this problem?

作者: kyl 的来源 发布者: 2017 年 9 月 15 日

回应 2


0

333 作者的声誉

First, always try cleaning the project as suggested. If that didn't work, try manually installing the framework. Here's Google's page on how to.

作者: EthanBar 发布者: 2017 年 9 月 15 日

1

1075 作者的声誉

决定

self question self answer

I solved this problem.

  • First I removed all the libraries in Podfile. and then I ran "pod install" to remove all the libraries from project.

  • I attached again libraries to Podfile. and executed again "pod install" to reinstall all the libraries. then errors are disappeared.

  • I have met new error "Command /usr/bin/codesign failed with exit code 1". To fix this goto project root folder in terminal and exeucted follow command

    xattr -rc .

after that everything is ok. thank you everyone!

作者: kyl 发布者: 2017 年 9 月 15 日
32x32