java.lang.NoSuchMethodError:org.springframework.kafka.listener.adapter.MessagingMessageListenerAdapter。<init>(Ljava / lang / reflect / Method;)V

spring-cloud-stream spring-kafka

1086 观看

1回复

331 作者的声誉

我正在java.lang.NoSuchMethodError: org.springframework.kafka.listener.adapter.MessagingMessageListenerAdapter.<init>(Ljava/lang/reflect/Method;)V使用Spring-cloud-dependencies版本Camden SR5。谁能帮我解决这个问题?

作者: maya16 的来源 发布者: 2017 年 9 月 15 日

回应 1


1

2334 作者的声誉

决定

这是一个已知问题,报告在这里:https : //github.com/spring-cloud/spring-cloud-release/issues/70

当前,解决方法(从以上建议)是:

您在这里有两个选择:将Spring Integration Kafka的版本升级到2.1.0,并使其与其余的Spring Boot依赖项集内联,或者像您所做的那样降级Spring Kafka的版本。使用Dalston将带来一致的依赖关系集。

作者: Ilayaperumal Gopinathan 发布者: 2017 年 9 月 15 日
来自类别的问题 :
32x32