流浪汉vagrantfile版本不匹配

vagrant virtualbox

665 观看

1回复

66 作者的声誉

我的版本:

VBoxManage --version
5.1.28r117968

vagrant -v
Vagrant 2.0.0

当我运行流浪汉时,我会得到类似的输出

Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

This Vagrant environment has specified that it requires the Vagrant
version to satisfy the following version requirements:

~> 1.5

You are running Vagrant 2.0.0, which does not satisfy
these requirements. Please change your Vagrant version or update
the Vagrantfile to allow this Vagrant version. However, be warned
that if the Vagrantfile has specified another version, it probably has
good reason to do so, and changing that may cause the environment to
not function properly.

我需要什么?

作者: mak 的来源 发布者: 2017 年 9 月 15 日

回应 1


0

37746 作者的声誉

罪魁祸首Vagrant-bershelf对vagrant的1.x分支有很强的依赖性,您可以从此行代码中进行检查

module Berkshelf
  class Plugin < Vagrant.plugin("2")
    # Require a particular version of Vagrant
    Vagrant.require_version("~> 1.5")

    name "berkshelf"

您有以下可能的解决方案:

  • 如果您不需要该插件,只需将其卸载
  • 您可能需要让插件的所有者立即升级到2.x(或通过升级向项目提供拉取请求)
  • 恢复到1.9x流浪汉版本
作者: Frédéric Henri 发布者: 2017 年 9 月 15 日
32x32