Mapzen buildings polygons are clipped when draw on map

mapzen

99 观看

2回复

10 作者的声誉

I have been using the Mapzen Vector Tile Service . When I request a certain area I get different results.

hxxps://tile.mapzen.com/mapzen/vector/v1/all/18/214238/114415.json?api_key=[my_key]

Note: that my key is muted.

This is from mapzen

This is from my server

They are both called with the same parameter 18/214238/114415.json, however the request from my server have my buildings clipped.

I want the builds to be not clipped, I have tested that a building is bounded to 1 tile, if it is larger than the tile it will be clipped. However Mapzen servers seems to not getting the clip issue so I am guessing there is something wrong with my settings.

What setting am I missing? Is there any setting from tileserver,tileqeue or vectordata-source I am missing?

作者: Airborne STD 的来源 发布者: 2017 年 9 月 15 日

回应 2


0

116 作者的声誉

Try the clip_factor parameter.

Here is Mapzen's configuration: https://github.com/tilezen/vector-datasource/blob/e87ac739b3e98f7c5363df3af06944bcec774c1c/queries.yaml#L231

A clip_factor: 3.0 will clip buildings only when they span more than three tiles.

作者: rhonda 发布者: 2017 年 9 月 15 日

0

16 作者的声誉

决定

We suspect you're using master of all the Tilezen repos instead of the latest tagged releases. The recommended production combo is documented in the release notes here (this is what's used in Mapzen's production stack today):

https://github.com/tilezen/vector-datasource/releases/tag/v1.4.0-docs1

Using v1.4.0 the clip_factor should be respected. But that is currently not supported in master due to some large refactoring that's on-going. We may add it back to solve some landuse kind intersection bugs we're seeing, but that work is not yet scheduled.

If you want to hack on master yourself the relevant clip to expand is here:

https://github.com/tilezen/vector-datasource/blob/82127d1b1040ae6f1b9a38ab8b348cb3b6f97e4f/queries/planet_osm_polygon.jinja2#L17

Hope this helps!

作者: Nathaniel Kelso 发布者: 2017 年 9 月 20 日
32x32