在iOS 11上使用Xcode 8

ios xcode ios11

58942 观看

4回复

6081 作者的声誉

我想在iOS 11上使用Xcode 8。

我应该升级我的Xcode。但是,我的代码无法由新的编译器构建,因此我想继续使用Xcode 8。

在此处输入图片说明

我该如何实现?

苹果在WWDC 2017上展示了iOS 11的一些新功能。

作者: Nazmul Hasan 的来源 发布者: 2017 年 6 月 6 日

回应 (4)


63

886 作者的声誉

到目前为止,这仅适用于iOS设备上的调试,不适用于模拟器

除非您具有iOS 11版本的DeviceSupport文件夹,否则Xcode 8将不支持。

  1. 您可以下载Xcode 9 beta(最新的Xcode 9)或从其他用户那里获得DeviceSupport文件夹。

  2. 只需将其复制到您的文件夹或创建符号链接

sudo ln -s /Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0\ \(15A372\) /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0

参考:将Xcode 7与iOS 10结合使用

作者: yudun1989 发布者: 06.06.2017 06:44

5

6766 作者的声誉

我更喜欢复制所有文件夹:

/Volumes/**HighSierra**/Applications/Xcode-**beta.app**/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0\ \(15A5278f\)

至:

 /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/**11** 

我可以确认可以在装有iOS 11的iPhone 7上运行

作者: ingconti 发布者: 06.06.2017 07:50

60

3623 作者的声誉

决定

检查一下:到目前为止,这仅适用于在iOS设备上进行调试,而不能用于模拟器

  1. 从Apple下载SDK
  2. 将此iOS 11.0图像文件复制到:/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
  3. 重新启动Xcode。
作者: Sour LeangChhean 发布者: 08.06.2017 04:40

7

90 作者的声誉

我做到了,这很好,我仍然可以使用Xcode 8 + Swift 3在商业应用程序上工作,也可以使用Swift 4探索Xcode 9 beta。只需下载Xcode 9,并在Xcode 8首选项内,将命令行工具设置为使用9.0。 。

Xcode首选项>位置

作者: Daniel Bonates 发布者: 21.06.2017 11:10
32x32